博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
poj2312--Battle City(Bfs)
阅读量:6705 次
发布时间:2019-06-25

本文共 2866 字,大约阅读时间需要 9 分钟。

Battle City
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7712 Accepted: 2582

Description

Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 
What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). 
Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

Input

The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

Sample Input

3 4 
YBEB 
EERE 
SSTE 
0 0

Sample Output

8

Source

,鲁小石

优先队列, 没啥了。。。。。。。。

#include <queue>
#include <cstdio>
#include <iostream>
using 
namespace std;
char map[
300][
300]; 
int ac[
4][
2] = {
0
1
0, -
1, -
1
0
1
0};
int n, m;
struct Maze
{
    
int x, y, step;
    friend 
bool 
operator < (Maze x, Maze y)
    {
        
return x.step > y.step;        
    } 
}r, s, t;
int Bfs(
int a, 
int b)
{
    r.x = a; r.y = b; r.step = 
0;
    map[a][b] = 
'
S
';
    priority_queue<Maze> Q;
    Q.push(r);
    
while(!Q.empty())
    {
        s = Q.top(); Q.pop();
        
for(
int i = 
0; i < 
4; i++)
        {
            t.x = s.x + ac[i][
0];
            t.y = s.y + ac[i][
1];
            t.step = s.step + 
1;
            
if(t.x >= 
0 && t.x < n && t.y >= 
0 && t.y < m && map[t.x][t.y] != 
'
R
' && map[t.x][t.y] != 
'
S
')
            {
                
if(map[t.x][t.y] == 
'
T
')
                    
return t.step;
                
if(map[t.x][t.y] == 
'
B
')
                {
                    t.step += 
1;
                }
                map[t.x][t.y] = 
'
S
';
                Q.push(t);    
            } 
        } 
    }
    
return -
1
int main() 
{
    
while(~scanf(
"
%d %d
", &n, &m), n+m)
    {
        
int x, y;
        
for(
int i = 
0; i < n; i++)
        {
            scanf(
"
%s
", map[i]);
            
for(
int j = 
0; j < m; j++)
            {
                
if(map[i][j] == 
'
Y
')
                {
                    x = i;
                    y = j;
                }
            }
        }
        printf(
"
%d\n
", Bfs(x, y));
    }
    
return 
0;}

 

转载于:https://www.cnblogs.com/soTired/p/4779133.html

你可能感兴趣的文章
html5调用摄像头拍照
查看>>
Server远程带外管理--IPMI
查看>>
Java HotSpot VM Options (官方)
查看>>
Highcharts 条形图
查看>>
第一次用虚拟机装系统出现这种情况!(操作系统已禁用CPU)
查看>>
零基础搭建自己的博客
查看>>
Amazon桌面云和X9桌面云的比较
查看>>
网络工程师面试记
查看>>
我的友情链接
查看>>
利用Nginx做负载均衡
查看>>
CentOS 7 本地yum源配置
查看>>
python 将unix文件转成dos文件
查看>>
ORA-01114: IO error writing block to file
查看>>
javascript 使用btoa和atob来进行Base64转码和解码
查看>>
让Windows7更安全 不得不知的帐户设置
查看>>
设计模式系列-享元模式
查看>>
电子课本的未来
查看>>
CactiEZ中文版10.1正式发布
查看>>
Linux命令之top
查看>>
中断和异常
查看>>